En un bucle del tipo repetir hasta la condición de finalización de la ejecución del bucle de forma repetitiva se encuentra al final del mismo. En programación va a resultar adecuado el uso de este tipo de bucles en aquellos casos que en cualquiera de los casos, la primera vez, el programa deba entrar dentro del bucle. Un ejemplo es la definición de un menú de opciones el cual, al menos una vez, debe de ser mostrado en pantalla.

Veamos el siguiente programa en pseudocódigo de Pseint en donde se define un menú de opciones contenido en el interior de un bucle repetir hasta:

Algoritmo repetirhasta
definir op Como Entero
Repetir
escribir «1. Suma» con salto
escribir «2. Resta» con salto
escribir «3. Multiplicación» con salto
escribir «4. División» con salto
escribir «5. Salir» con salto
Escribir «Elige una opción»
leer op
Hasta Que op=5
FinAlgoritmo

En el siguiente video se explica el funcionamiento de este tipo de bucles: