Vamos a ver un programa que después de solicitar al usuario la inserción de tres números mostrará por pantalla quén ha sido el mayor, el mediano y el menor.

El pseudocódigo Pseint es el siguiente:

Algoritmo menormedianomayor1
definir n1, n2, n3 como entero
escribir «Introduce un primer número» con salto
leer n1
escribir «Introduce un segundo número» con salto
leer n2
escribir «Introduce un tercer número» con salto
leer n3
si n1>n2 y n2>n3
escribir » El mayor es: » n1
escribir «El mediano es: » n2
escribir «El menor es: » n3
FinSi
si n1>n3 y n3>n2
escribir » El mayor es: » n1
escribir «El mediano es: » n3
escribir «El menor es: » n2
FinSi
si n2>n1 y n1>n3
escribir » El mayor es: » n2
escribir «El mediano es: » n1
escribir «El menor es: » n3
FinSi
si n2>n3 y n3>n1
escribir » El mayor es: » n2
escribir «El mediano es: » n3
escribir «El menor es: » n1
FinSi
si n3>n1 y n1>n2
escribir » El mayor es: » n3
escribir «El mediano es: » n1
escribir «El menor es: » n2
FinSi
si n3>n2 y n2>n1
escribir » El mayor es: » n3
escribir «El mediano es: » n2
escribir «El menor es: » n1
FinSi
FinAlgoritmo

Par la realización de este programa se han tenido en cuenta cada una de las seis posibilidades existentes mediante el empleo de seis instrucciones condicionales si con una doble condición cada una de ellas.

Seguidamente se puede ver un video en el que se comenta el funcionamiento de dicho programa: