Dado el programa anterior que permitía calcular el mayor, el mediano y el menor de tres números introducidos por el usuario, seguidamente se va a resolver este problema de otra forma: se van a suprimir las condiciones dobles de cada instrucción condicional para expandir un condicional si mediante otros condicionales sí internos y los casos contrarios (sino) de cada uno de ellos.

El pseudocódigo correspondiente es el siguiente:

Algoritmo menormayormedio
definir n1,n2,n3 como entero
escribir «introduce un primer número» con salto
leer n1
escribir «Introduce un segundo número» con salto
leer n2
escribir «Introduce un tercer número» con salto
leer n3
si n1>n2 Entonces
si n1>n3 Entonces
escribir «El número » n1 » es el mayor»
si n2>n3 Entonces
escribir «El número » n2 » es el mediano»
escribir «El número » n3 » es el menor»
SiNo
escribir «El número » n3 » es el mediano»
escribir «El número » n2 » es el menor»
FinSi
SiNo
escribir «El número » n3 » es el mayor»
escribir «El número » n1 » es el mediano»
escribir «El número » n2 » es el menor»
FinSi
SiNo

si n2>n3 Entonces
escribir «El número » n2 » es el mayor»
si n1>n3 Entonces
escribir «El número » n1 » es el mediano»
escribir «El número » n3 » es el menor»
SiNo
escribir «El número » n3 » es el mediano»
escribir «El número » n1 » es el menor»
FinSi
sino

escribir «El número » n3 » es el mayor»
escribir «El número » n2 » es el mediano»
escribir «El número » n1 » es el menor»

FinSi
FinSi

A continuación tenemos un video en el que se explican cada uno de los pasos del programa:

FinAlgoritmo